Filtering Web HTTPS dengan matcher 'TLS-HOST'

Mulai versi 6.41, MikroTik menambahkan sebuah parameter pada menu IP Firewall dimana dengan parameter tersebut kita bisa dengan mudah melakukan Filtering Web HTTPS dengan matcher ‘TLS-HOST’. Penambahan ini memang didasarkan pada banyaknya website yang sekarang ini menggunakan protokol HTTPS untuk komunikasinya.

Parameter ini dikenalkan pada versi 6.41 namun secara fungsinya dapat dilakukan dengan baik di versi selanjutnya yaitu versi 6.42. Sementara ini memang v6.42 masih dalam ‘release-candidate’ (RC). Penggunaan parameter ini juga tidak terlalu sulit, seperti halnya kita menggunakan parameter ‘Content’. Untuk parameternya disini disebut dengan ‘TLS-HOST’ yang ada pada tab ‘Advance’ di menu Firewall.

Sebagai contoh disini kita akan melakukan blocking terhadap situs-situs HTTPS diantaranya seperti Facebook, Youtube (google video).

https mikrotik

Untuk Script CLI seperti berikut:

/ip firewall filter
add action=drop chain=forward dst-port=443 in-interface=ether3 protocol=tcp tls-host=*facebook.com*
add action=drop chain=forward dst-port=443 in-interface=ether3 protocol=tcp tls-host=*mikrotik.com*
add action=drop chain=forward dst-port=443 in-interface=ether3 protocol=tcp tls-host=*googlevideo.com*
add action=drop chain=forward dst-port=443 in-interface=ether3 protocol=tcp tls-host=*gmail.com*

Dengan pengaturan rule seperti diatas, jika kita melakukan akses ke situs yang telah kita definisikan pada rule tersebut maka trafik akan di-drop.

firewall mikrotik

Hal ini bisa dijadikan sebagai alternatif yang bisa dicoba untuk filtering trafik browsing halaman website HTTPS, yang mana sebelumnya kita menggunakan fitur seperti content, L7, Dinamic Address List, DNS Static.

Sharing is caring!

Baca Juga  OSPF over VPN PPTP

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *