Implementasi Penggunaan PCQ Bagi ISP Untuk Mendapatkan Hasil Yang Maksimal

Implementasi Penggunaan PCQ Bagi ISP Untuk Mendapatkan Hasil Yang Maksimal

Implementasi Penggunaan PCQ Bagi ISP Untuk Mendapatkan Hasil Yang Maksimal – Melihat banyaknya pertanyaan mengenai pembagian sharing bandwith yang adil dan yang pasti bisa membatasi semua jenis trafik baik IDM maupun P2P sehingga gak perlu takut kecolongan, saya coba untuk mensharing.

Konfigurasi Jaringan :
Public — (10.0.0.1/24) MT (192.168.1.1/24)— Local

Skenarionya seperti ini :
Client 192.168.1.10 — Bandwidth 512kbps 1:1 (corporate)
(512k up / 512 down)
Client 192.168.1.20, 21, 22, 23 — Bandwidth 384kbps 1:4 (personal)
(64k up / 384 down)

Pertama-tama lakukan mangle :

Untuk trafik upload corporate

/ip firewall mangle add chain=prerouting src-address=192.168.1.10 in-interface=Local action=mark-packet
new-packet-mark=corporate-up passthrough=no

Untuk trafik download corporate

/ip firewall mangle add chain=forward src-address=192.168.1.10 action=mark-connection new-connectionmark=corporate-conn passthrough=yes

/ip firewall mangle add chain=forward connection-mark=corporate-conn in-interface=Public action=markpacket new-packet-mark=corporate-down passthrough=no

Untuk trafik upload personal

/ip firewall mangle add chain=prerouting src-address=192.168.1.20 in-interface=Local action=mark-packet
new-packet-mark=personal-up passthrough=no

/ip firewall mangle add chain=prerouting src-address=192.168.1.21 in-interface=Local action=mark-packet
new-packet-mark=personal-up passthrough=no

/ip firewall mangle add chain=prerouting src-address=192.168.1.22 in-interface=Local action=mark-packet
new-packet-mark=personal-up passthrough=no

/ip firewall mangle add chain=prerouting src-address=192.168.1.23 in-interface=Local action=mark-packet
new-packet-mark=personal-up passthrough=no

Untuk trafik download personal

/ip firewall mangle add chain=forward src-address=192.168.1.20 action=mark-connection new-connectionmark=personal-conn passthrough=yes

/ip firewall mangle add chain=forward src-address=192.168.1.21 action=mark-connection new-connectionmark=personal-conn passthrough=yes

/ip firewall mangle add chain=forward src-address=192.168.1.22 action=mark-connection new-connectionmark=personal-conn passthrough=yes

/ip firewall mangle add chain=forward src-address=192.168.1.23 action=mark-connection new-connectionmark=personal-conn passthrough=yes

/ip firewall mangle add chain=forward connection-mark=personal-conn in-interface=Public action=markpacket new-packet-mark=personal-down passthrough=no

Harap diperhatikan untuk mark-packet maka passthrough=no sedangkan untuk mark-connection
passthrough=yes

Nah setelah beres urusan mangle, kita lanjut ke pembuatan queue tree :

/queue tree add name=down parent=Local queue=default

/queue tree add name=up parent=global-in queue=default

untuk download kita menggunakan in-interface kita dalam hal ini Local, sedangkan untuk upload kita
menggunakan global-in

selanjutnya kita tambahkan type baru di queue kita :

yang harus kita tambahkan melihat skenario diatas adalah PCQ untuk paket corporate 512kbps (1:1) dan paket personal 384kbps (1:4).

Untuk paket corporate kita langsung menetapkan angka 512kbps, sedangkan untuk personal kita tidak dapat menetapkan angka disini karena bandiwdth yang akan diterima oleh paket personal tergantung seberapa banyak user yang online, jadi jika hanya 1 orang online akan mendapatkan bw penuh 384kbps, kalau 2 orang online maka masing-masing akan mendapatkan 192kbps dan seterusnya.

/queue type add name=512-down kind=pcq pcq-rate=512k pcq-classifier=dst-address pcq-total-limit=2000

/queue type add name=512-up kind=pcq rate=512k pcq-classifier=src-address pcq-total-limit=2000

/queue type add name=auto-down kind=pcq pcq-rate=0 pcq-classifier=dst-address pcq-total-limit=2000

/queue type add name=auto-up kind=pcq rate=0 pcq-classifier=src-address pcq-total-limit=2000

kita menggunakan 0 pada paket personal karena MT akan menghitung berapa besar bw yang tersedia pada
saat client melakukan koneksi.

Nah setelah itu kita kembali ke queue tree dan menambahkan :

Paket corporate

/queue tree add name=corp-down packet-mark=corporate-down parent=down queue=512-down
/queue tree add name=corp-up parent=up packet-mark=corporate-up queue=512-up

Paket personal

/queue tree add name=per-down packet-mark=personal-down parent=down queue=auto-down maxlimit=384k
/queue tree add name=per-up parent=up packet-mark=personal-up queue=auto-up max-limit=64k

Done.

Setelah melakukan semua hal ini silahkan dociba gunakan aplikasi P2P ataupun downloader, seharusnya semuanya sudah dapat ter-shaping dengan baik.

Baca Juga : Load Balance Metode PCC Dengan Fail Over Mikrotik

Settingan diatas cocok diterapkan buat konfigurasi seperti diterangkan diatas, tanpa menggunakan proxy internal MT dan hanya 2 interface, untuk penggunakan proxy internal dan lebih banyak interface diperlukan sedikit perubahan dan penambahan pada script diatas.

Related posts

One Thought to “Implementasi Penggunaan PCQ Bagi ISP Untuk Mendapatkan Hasil Yang Maksimal

Leave a Comment