Konfigurasi OSPF Pada Cisco

Konfigurasi OSPF Pada Cisco

Pada kesempatan kali ini saya akan memberikan sebuah simulasi jaringan yang menggunakan protokol routing OSPF. Saya menggunakan software simulator Cisco Paket Tracer. Berikut cara Konfigurasi OSPF Pada Cisco. Langsung saja pertama-tama buat buat topologi seperti gambar dibawah ini :

ospf

Kemudian lakukan konfigurasi IP address di Router 0 dan Router 1 perintahnya seperti dibawah ini :

R1>en
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int fa 0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config-if)#no shutdown

R2>en
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int fa 0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#

Ketika mengaktifkan interface FastEthernet dengan command no shutdown , IOS akan memberikan informasi kepada kita bahwa interface FastEthernet dan line protocol sudah up. Untuk melihat message secara remote, ketikkan command enable terminal monitor pada semua line vty. Secara default, untuk meng-enable IP routing semua Cisco router menggunakan command ip routing. Anda dapat men-disable IP routing dengan command no ip routing.

Untuk menampilkan IP address di setiap Router yang sedang up
R1#show interface fa 0/0
FastEthernet0/0 is up, line protocol is up interface up dan active Hardware is Gt96k FE, address is c000.09bc.0000 (bia c000.09bc.0000) Internet address is 12.12.12.1/24 IP address yang telah kita setting MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec, reliability 255/255, txload 1/255, rxload 1/255

R2#show interface fa 0/0
FastEthernet0/0 is up, line protocol is up Hardware is Gt96k FE, address is c001.09bc.0000 (bia c001.09bc.0000) Internet address is 12.12.12.2/24 MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec, reliability 255/255, txload 1/255, rxload 1/255

Kemudian lakukan ping koneksi dari Router 0 ke Router 1 dan sebaliknya

R1#ping 12.12.12.2
Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds: .!!!! Success rate is 80 percent (4/5), round-trip min/avg/max = 44/60/68 ms

R2#ping 12.12.12.1
Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 64/76/128 ms

Selanjut kita membuat topologi OSPF single area

Konfigurasi OSPF Pada Cisco

Setting IP address pada loopback di R1

R1(config)#int lo 0
interface loopback 0
R1(config-if)#
*Mar 1 00:15:36.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up interface loopback otomatis up tanpa command no shutdown
R1(config-if)#ip address 192.168.1.1 255.255.255.255
R1(config-if)#int lo 1
*Mar 1 00:16:06.067: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1(config-if)#ip address 192.168.1.2 255.255.255.255
R1(config-if)#int lo 2
*Mar 1 00:16:16.247: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
R1(config-if)#ip address 192.168.1.3 255.255.255.255
R1(config-if)#

Selanjutnya setting semua IP address interface loopback di R2.

Interface loopback pada lab ini berfungsi sebagai virtual subnet. Sehingga seolah-olah kita memiliki 6 subnet yang dihubungkan melalui koneksi serial antara R1 dan R2. Loopback sangat bermanfaat untuk nge-lab jika resource computer kita minimal, sehingga tidak perlu menggunakan jumlah router yang banyak. Pada semua design network OSPF yang bagus, backbone area biasanya disetting sebagai area 0. Maka, area 0 sering disebut juga sebagai backbone area, karena berfungsi untuk mengkoneksikan antar area. Untuk mensetting OSPF routing protocol gunakan command router ospf process-id. Proses ID hanya berlaku untuk local router, sehingga tidak berpengaruh untuk router lain. Proses ID boleh beda antar router dan dalam satu router bisa menjalankan multiple proses ID. Setelah itu setting dengan sub-command network address wildcard-mask area area-id. Tentukan network address yang akan diadvertised menggunakan OSPF. Dalam satu area-id, router harus memiliki area-id yang sama sehingga bisa membentuk adjacency.

Setting OSPF di R1

R1(config)#router ospf 1
R1(config-router)#network 12.12.12.0 0.0.0.255 area 0
R1(config-router)#network 192.168.1.1 0.0.0.0 area 0
R1(config-router)#network 192.168.1.2 0.0.0.0 area 0
R1(config-router)#network 192.168.1.3 0.0.0.0 area 0

Setting OSPF di R2

R2(config)#router ospf 2
R2(config-router)#network 12.12.12.0 0.0.0.255 area 0
R2(config-router)#network 192.168.1.4 0.0.0.0 area 0
R2(config-router)#network 192.168.1.5 0.0.0.0 area 0
R2(config-router)#network 192.168.1.6 0.0.0.0 area 0

Wildcard mask 0.0.0.0 artinya harus match. Wildcard mask 0.0.0.255 artinya hanya 3 oktet yang match dan octet keempat ignored. Contoh untuk network 12.12.12.0 0.0.0.255 area 0 artinya 12.12.12.1 sampai 12.12.12.254. Pada lab ini, Anda dapat mengkonfigurasi IP address apa saja yang berada pada range 12.12.12.1 – 12.12.12.254 untuk di area 0 pada interface s0/0 R1. Karena pada lab ini menggunakan OSPF Single-Area yaitu area 0, maka semua router harus memiliki area yang sama agar bisa membentuk adjacency sehingga semua network dapat berkomunikasi. Untuk area yang sama biasanya disebut juga Intra Area, sedangkan untuk area yang berbeda Inter Area.

Baca Juga : Cara Cepat Mengenal dan Mempelajari Cisco Router

Menampilkan routing table di R1

R1#show ip route

Untuk OSPF kodenya O. Lihat pada kode O, network address 192.168.1.4 – 192.168.1.6 ada di R2. Untuk menuju ke network tersebut dari R1 menggunakan jalur 12.12.12.2. IP 12.12.12.2 merupakan IP address s0/0 R2. “via” artinya gateway yang mau dilewati / lewat mana. Simplenya untuk menuju ke network 192.168.1.4 – 192.168.1.6 melalui 12.12.12.2.

Untuk output agar spesifik routing OSPF saja yang ditampilkan bisa menggunakan command dibawah :

Menampilkan routing table di R1

R1#show ip route ospf
192.168.1.0/32 is subnetted, 6 subnets
O 192.168.1.5 [110/65] via 12.12.12.2, 00:31:02, Serial0/0
O 192.168.1.4 [110/65] via 12.12.12.2, 00:31:02, Serial0/0
O 192.168.1.6 [110/65] via 12.12.12.2, 00:31:02, Serial0/0

Menampilkan routing table di R2

R2#show ip route ospf
192.168.1.0/32 is subnetted, 6 subnets
O 192.168.1.1 [110/65] via 12.12.12.1, 00:32:59, Serial0/0
O 192.168.1.3 [110/65] via 12.12.12.1, 00:32:59, Serial0/0
O 192.168.1.2 [110/65] via 12.12.12.1, 00:32:59, Serial0/0

Ping dari S0/0 R1 ke Interface Loopback 2 di R2

R1#ping 192.168.1.6 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/13/28 ms

Ping dari S0/0 R2 ke Interface Loopback 0 di R1

R2#ping 192.168.1.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/12/32 ms

Baca Juga : CISCO Switch – Vlan dan Trunking

Metric OSPF pada Lab ini yaitu 65, sedangkan Administrative Distance OSPF = 110. Dapat dilihat pada baris berikut : O 192.168.1.5 [110/65] via 12.12.12.2, 00:31:02, Serial0/0 R1 secara dinamis mempelajari remote network pada R2 melalui next hop address 12.12.12.2 dan outbound interface Serial 0/0. OSPF membentuk neighborship dengan adjacent router dengan melakukan pertukaran Paket Type 1 (Hello). Berikut ini kondisi yang harus dipenuhi oleh dua router untuk membentuk neighbor :
– Masing-masing router harus berada pada subnet yang sama dan menggunakan subnet mask yang sama
– Masing-masing router harus memiliki hello dan dead intervals yang sama
o Hello interval mengidentifikasikan berapa frekuensi neighbor router melakukan pertukaran hello packet
o Dead interval mengidentifikasikan jumlah waktu yang diijinkan tanpa mengirimkan hello packet.
o Note : jika secara periodic hello packet tidak diterima dalam jangka waktu dead interval, maka router mengasumsikan bahwa neighbor router telah offline.
– Masing-masing router harus menggunakan area yang sama
– Jika autentikasi dibutuhkan, masing-masing router harus memenuhi requirement autentikasi

Adjacent router adalah router yang menjadi tetangga (neighbor) dan akan melakukan sharing atau pertukaran informasi database yang dimiliki.

Itulah sedikit tutorial tentang bagaimana cara Konfigurasi OSPF Pada Cisco

Incoming search terms:

Related posts

One Thought to “Konfigurasi OSPF Pada Cisco

Leave a Comment