Load Balancing Dan Fail Over Di MikroTik Menggunakan Metode NTH

Load Balancing Dan Fail Over Di MikroTik Menggunakan Metode NTH

Load balancing adalah teknik untuk mendistribusikan beban trafik pada dua atau lebih jalur koneksi secara seimbang, agar trafik dapat berjalan optimal, memaksimalkan throughput, memperkecil waktu tanggap dan menghindari overload pada salah satu jalur koneksi. Kali ini saya akan sedikit share kepada kalian tentang Load Balancing Dan Fail Over Di MikroTik menggunakan metode NTH

Kondisi : ISP dimana kita bekerja sebagai Administrator menggunakan lebih dari satu gateway untuk terhubung ke Internet. Semuanya harus dapat melayani layanan upstream & downstream. Karena akan beda kasusnya apabila salah satunya hanya dapat melayani downstream, contohnya jika menggunakan VSAT DVB One-way.

Untuk kasus ini dimisalkan ISP memiliki 2 jalur ke Internet. Satu menggunakan akses DSL (256 Kbps) dan lainnya menggunakan Wireless (512 Kbps). Dengan rasio pemakaian DSL:Wireless = 1:2 .

Yang akan dilakukan :

  • Menggunakan semua jalur gateway yang tersedia dengan teknik load-balancing.
  • Menjadikan salah satunya sebagai back-up dengan teknik fail-over.

OK, mari saja kita mulai eksperimennya :

IP address untuk akses ke LAN :

> /ip address add address=192.168.0.1/28 interface=LAN

IP address untuk akses ke jalur DSL :

> /ip address add address=10.32.57.253/29 interface=DSL

IP address untuk akses ke jalur Wireless :

> /ip address add address=10.9.8.2/29 interface=WIRELESS

Tentukan gateway dengan rasionya masing-masing :

> /ip route add gateway=10.32.57.254,10.9.8.1,10.9.8.1

2. Pada kasus untuk teknik fail-over. Diasumsikan jalur utama melalui Wireless dengan jalur DSL sebagai back-up apabila jalur utama tidak dapat dilalui. Untuk mengecek apakah jalur utama dapat dilalui atau tidak, digunakan command ping.

> /ip firewall mangle add chain=prerouting src-address=192.168.0.0/28 action=mark-routing new-routingmark=SUBNET1-RM

> /ip route add gateway=10.9.8.1 routing-mark=SUBNET1-RM check-gateway=ping

> /ip route add gateway=10.32.57.254

Another Load Balancing Tutorial

  • Masalah IP Address silahkan di definisikan sendiri.
  • Bikin Mangle :

add chain=prerouting in-interface=LocalHost connection-state=new nth=2,1,0 \
action=mark-connection new-connection-mark=one passthrough=yes \
comment=”Load Balancing – 3 Gateway by Raden Dody uhuy” disabled=no
add chain=prerouting in-interface=LocalHost connection-mark=one \
action=mark-routing new-routing-mark=one passthrough=no comment=”” \
disabled=no
add chain=prerouting in-interface=LocalHost connection-state=new nth=2,1,1 \
action=mark-connection new-connection-mark=two passthrough=yes comment=”” \
disabled=no
add chain=prerouting in-interface=LocalHost connection-mark=two \
action=mark-routing new-routing-mark=two passthrough=no comment=”” \
disabled=no
add chain=prerouting in-interface=LocalHost connection-state=new nth=2,1,2 \
action=mark-connection new-connection-mark=three passthrough=yes comment=”” \
disabled=no
add chain=prerouting in-interface=LocalHost connection-mark=three \
action=mark-routing new-routing-mark=three passthrough=no comment=”” \
disabled=no

  • Bikin NAT

/ ip firewall nat
add chain=srcnat out-interface=[nama interface 1] connection-mark=one \
action=masquerade comment=”NAT for Load Balancing by Mbah Dody au ah gelap” disabled=no
add chain=srcnat out-interface=[nama interface 2] connection-mark=two \
action=masquerade comment=”” disabled=no
add chain=srcnat out-interface=[nama interface 3] connection-mark=three \
action=masquerade comment=”” disabled=no

  • Bikin Routing

/ ip route
add dst-address=0.0.0.0/0 gateway=[IP Interface 1] scope=255 target-scope=10 \
routing-mark=one comment=”Route for Load Balancing by Ki Dody oye” disabled=no
add dst-address=0.0.0.0/0 gateway=[IP Interface 2] scope=255 target-scope=10 \
routing-mark=two comment=”” disabled=no
add dst-address=0.0.0.0/0 gateway=[IP Interface 3] scope=255 target-scope=10 \
routing-mark=three comment=”” disabled=no

Sudah saya coba dan sukses, dulu ada dan banyak website yang tidak mau menerima koneksi dari client yang load balancing terutama website yang mengandung banyak security, tapi sudah saya coba untuk akses www.klikbca.com, buka email nggak masalah, cuman tetep ada masalah, kenapa saldo saya nggak nambah-nambah ya ? Sory ngelantur.

Baca Juga : Load Balance Metode PCC Dengan Fail Over Mikrotik

Tapi tetep nanti akan ketemu website yg nggak mau menerima , utk itu perlu dibuatkan mangle khusus untuk
web yg nggak mau tsb, berikut sciptnya :

/ ip firewall mangle
add chain=prerouting in-interface=LocalHost dst-address-list=Nggak Doyan Load Balancing \
action=mark-routing new-routing-mark=one passthrough=yes comment=”Ora \
Doyan Load Balancing” disabled=no

Perhatian : Script tersebut harap di letakkan sebelum script load balancing.

  • Buat Address List website yg nggak mau menerima client Load Balancing.

/ ip firewall address-list
add list=Nggak Doyan Load Balancing address=[IP Addressnya berapa ?] comment=”” disabled=no

Related posts

One Thought to “Load Balancing Dan Fail Over Di MikroTik Menggunakan Metode NTH

Leave a Comment