Load Balancing nth buat Mikrotik Ver 3.xx dan 2.9xx

Load Balancing nth buat Mikrotik Ver 3.xx dan 2.9xx

Load Balancing nth buat Mikrotik Ver 3.xx dan 2.9xx – Masih banyak orang yang sering menanyakan cara load balancing atau pun cara mengabungkan 2 line speedy. disini saya ingin membagikan contoh load balancing nth yang saya pakai di server saya.

settingan pppoe speedy saya sudah saya tanam di dalam modem jadi saya gak pakai pppoe di mikrotik. berikut contohnya buat mikrotik versi 3.xx (saya pakai di mikrotik 3.16) :
Ip Modem 01 : 192.168.1.1 interface=speedy1
IP Modem 02 : 192.168.2.1 interface=speedy2
IP Local : 10.18.92.1 interface=Local

Setting Buat Mangle

/ip firewall mangle
add chain=prerouting action=mark-connection new-connection-mark=Santaria1 \
passthrough=yes connection-state=new in-interface=Local nth=2,1 \
comment=”” disabled=no
add chain=prerouting action=mark-routing new-routing-mark=Santaria1 passthrough=no \
in-interface=HotSpot connection-mark=Santaria1 comment=”” disabled=no
add chain=prerouting action=mark-connection new-connection-mark=Santaria2 \
passthrough=yes connection-state=new in-interface=Local nth=1,1 \
comment=”” disabled=no
add chain=prerouting action=mark-routing new-routing-mark=Santaria2 passthrough=no \
in-interface=HotSpot connection-mark=Santaria2 comment=”” disabled=no

Setting NAT

/ip firewall nat
add chain=srcnat action=masquerade out-interface=speedy1
add chain=srcnat action=masquerade out-interface=speedy2
add chain=srcnat action=masquerade src-address=”10.18.92.0/24″

Setting Routenya

/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 \
routing-mark=Santaria1 comment=”” disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 \
routing-mark=Santaria2 comment=”” disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 \
comment=”primary connection” disabled=no

Baca Juga : Tutorial Mikrotik Load Balancing Winbox Version

Berikut scripting Load Balancing dengan konfigurasi 2 Line untuk Mikrotik versi 2.9.27

Sesuaikan IP masing-masing interface menurut network kita.
Note : 10.11.90.1 = IP Local
192.168.1.1 = IP Modem Speedy 1
192.168.2.1 = IP Modem Speedy 2

/ ip address
add address=10.11.90.1/24 network=10.11.90.0 broadcast=10.11.90.255 \
interface=local comment=”” disabled=no
add address=192.168.1.254/24 network=192.168.1.0 broadcast=192.168.1.255 \
interface=”Internet” comment=”” disabled=no
add address=192.168.2.254/24 network=192.168.2.0 broadcast=192.168.2.255 \
interface=”Speedy” comment=”” disabled=no

/ ip firewall mangle
add chain=prerouting in-interface=local connection-state=new nth=1,1,0 \
action=mark-connection new-connection-mark=santaria1 passthrough=yes \
comment=”Load Balancing Client” disabled=no
add chain=prerouting in-interface=local connection-mark=santaria1 \
action=mark-routing new-routing-mark=santaria1 passthrough=no comment=”” \
disabled=no
add chain=prerouting in-interface=local connection-state=new nth=1,1,1 \
action=mark-connection new-connection-mark=santaria2 passthrough=yes \
comment=”” disabled=no
add chain=prerouting in-interface=local connection-mark=santaria2 \
action=mark-routing new-routing-mark=santaria2 passthrough=no comment=”” \
disabled=no

/ ip firewall nat
add chain=srcnat out-interface=”Internet” action=masquerade comment=”” \
disabled=no
add chain=srcnat out-interface=”Speedy” action=masquerade comment=”” \
disabled=no

/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 \
routing-mark=santaria1 comment=”” disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 \
routing-mark=santaria2 comment=”” disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 \
comment=”primary connection” disabled=no

Baca Juga : Bagaimana Cara Install Mikrotik Di Router Board

Itulah cara Load Balancing nth buat Mikrotik Ver 3.xx dan 2.9xx semoga bermanfaat.

Related posts

Leave a Comment